Back

next-sanity@9.3.10

Failing

View npm
pnpm install --resolution-only
WARN Issues with peer dependencies found
.
├─┬ next 15.0.0-rc.0
├── ✕ unmet peer react@19.0.0-rc-f994737d14-20240522: found 19.0.0-rc-fb9a90fa48-20240614
└── ✕ unmet peer react-dom@19.0.0-rc-f994737d14-20240522: found 19.0.0-rc-fb9a90fa48-20240614
├─┬ @sanity/ui 2.6.3
├── ✕ unmet peer react@^18: found 19.0.0-rc-fb9a90fa48-20240614
├── ✕ unmet peer react-dom@^18: found 19.0.0-rc-fb9a90fa48-20240614
└─┬ framer-motion 11.0.8
├── ✕ unmet peer react@^18.0.0: found 19.0.0-rc-fb9a90fa48-20240614
└── ✕ unmet peer react-dom@^18.0.0: found 19.0.0-rc-fb9a90fa48-20240614
├─┬ sanity 3.49.0
├── ✕ unmet peer react@^18: found 19.0.0-rc-fb9a90fa48-20240614
├── ✕ unmet peer react-dom@^18: found 19.0.0-rc-fb9a90fa48-20240614
├─┬ @portabletext/editor 1.0.8
│ └── ✕ unmet peer react@"^16.9 || ^17 || ^18": found 19.0.0-rc-fb9a90fa48-20240614
├─┬ @rexxars/react-json-inspector 8.0.1
│ └── ✕ unmet peer react@"^15 || ^16 || ^17 || ^18": found 19.0.0-rc-fb9a90fa48-20240614
├─┬ @tanstack/react-virtual 3.0.0-beta.54
│ └── ✕ unmet peer react@"^16.8.0 || ^17.0.0 || ^18.0.0": found 19.0.0-rc-fb9a90fa48-20240614
├─┬ react-copy-to-clipboard 5.1.0
│ └── ✕ unmet peer react@"^15.3.0 || 16 || 17 || 18": found 19.0.0-rc-fb9a90fa48-20240614
├─┬ react-focus-lock 2.12.1
│ ├── ✕ unmet peer react@"^16.8.0 || ^17.0.0 || ^18.0.0": found 19.0.0-rc-fb9a90fa48-20240614
│ ├─┬ use-callback-ref 1.3.2
│ │ └── ✕ unmet peer react@"^16.8.0 || ^17.0.0 || ^18.0.0": found 19.0.0-rc-fb9a90fa48-20240614
│ ├─┬ use-sidecar 1.1.2
│ │ └── ✕ unmet peer react@"^16.8.0 || ^17.0.0 || ^18.0.0": found 19.0.0-rc-fb9a90fa48-20240614
│ └─┬ react-clientside-effect 1.2.6
│ └── ✕ unmet peer react@"^15.3.0 || ^16.0.0 || ^17.0.0 || ^18.0.0": found 19.0.0-rc-fb9a90fa48-20240614
└─┬ use-sync-external-store 1.2.2
└── ✕ unmet peer react@"^16.8.0 || ^17.0.0 || ^18.0.0": found 19.0.0-rc-fb9a90fa48-20240614
└─┬ next-sanity 9.3.10
└── ✕ unmet peer next@"^14.1 || >=14.3.0-canary.0 <14.3.0": found 15.0.0-rc.0
package.json
{
"dependencies": {
"next": ">=15.0.0-rc",
"next-sanity": "9.3.10",
"react": ">=19.0.0-rc",
"react-dom": ">=19.0.0-rc"
},
"packageManager": "pnpm@9.5.0"
}